re = /(Bit[^:]+):(\S+)/mi
str = 'Bit00:sadf::saf
BIt00:slkf
BIT123:sldfkajl;kasf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end