const regex = /^(\-{0,1})(?:(?:0*)(\d+))?((?:\.)(?:\d*?))?0*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\-{0,1})(?:(?:0*)(\\d+))?((?:\\.)(?:\\d*?))?0*$', 'gm')
const str = `-0.002506000
1
01
10
1.25
01.250
0
0002345000
0.25
0.50
0.5
0.75000
1000
0001.111
0001.5
.25
01234
-00.1
.2500
.0256
-.010`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);