package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\-{0,1})(?:(?:0*)(\d+))?((?:\.)(?:\d*?))?0*$`)
var str = `-0.002506000
1
01
10
1.25
01.250
0
0002345000
0.25
0.50
0.5
0.75000
1000
0001.111
0001.5
.25
01234
-00.1
.2500
.0256
-.010`
var substitution = "$1$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}