re = /^(1\s?)?(\d{6})?(\(\d{3}\)|\d{3})[\s\-]?\d{3}[\s\-]?\d{4}$/
str = '5555555555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end