using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(1\s?)?(\d{6})?(\(\d{3}\)|\d{3})[\s\-]?\d{3}[\s\-]?\d{4}$";
string input = @"5555555555";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}