$re = '/^(1\s?)?(\d{6})?(\(\d{3}\)|\d{3})[\s\-]?\d{3}[\s\-]?\d{4}$/';
$str = '5555555555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);