# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d{2}$"
test_str = ("# All POS codes should be 2 digits\n"
"# NOTE: Single digits should have a leading 0\n"
"# It's possible data loading might drop this! This regex would therefore fail\n"
"# This regex will also match codes that are currently unassigned\n"
"# - https://www.cms.gov/medicare/coding-billing/place-of-service-codes/code-sets\n"
"01\n"
"04\n"
"10\n"
"55\n"
"99\n"
"# Checks\n"
"0A\n"
"1\n"
"9\n"
"A0\n"
"--\n"
"990\n"
"010\n"
"**\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.