package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}$`)
var str = `# All POS codes should be 2 digits
# NOTE: Single digits should have a leading 0
# It's possible data loading might drop this! This regex would therefore fail
# This regex will also match codes that are currently unassigned
# - https://www.cms.gov/medicare/coding-billing/place-of-service-codes/code-sets
01
04
10
55
99
# Checks
0A
1
9
A0
--
990
010
**
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}