# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((\d{1,3}(,\d{3})*(\.\d+)?)|(\d+(\.\d+)?))$"
test_str = ("0,999,999,999,999,999.0\n"
"10,999,999,999,999,9899.9\n"
"99,999\n"
"9.99\n"
"9.9\n"
"999,99\n"
"9,999\n"
"999.0\n"
"abc123\n"
"66666666666666666666.098\n"
"888888888\n"
"0.999")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.