package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\d{1,3}(,\d{3})*(\.\d+)?)|(\d+(\.\d+)?))$`)
var str = `0,999,999,999,999,999.0
10,999,999,999,999,9899.9
99,999
9.99
9.9
999,99
9,999
999.0
abc123
66666666666666666666.098
888888888
0.999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}