use strict;
my $str = '0,999,999,999,999,999.0
10,999,999,999,999,9899.9
99,999
9.99
9.9
999,99
9,999
999.0
abc123
66666666666666666666.098
888888888
0.999';
my $regex = qr/^((\d{1,3}(,\d{3})*(\.\d+)?)|(\d+(\.\d+)?))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}