$re = '/^US\.BIN$/m';
$str = 'US.BIN
US.BINANCE
US.BI
US.B
US.
US
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);