package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^US\.BIN$`)
var str = `US.BIN
US.BINANCE
US.BI
US.B
US.
US
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}