using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^US\.BIN$";
string input = @"US.BIN
US.BINANCE
US.BI
US.B
US.
US
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}