// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@(?<planet>[A-Z,a-z]+)(?:[^@\-!:]+)?:(?<population>[\d]+)(?:[^@\-!:]+)?!(?<type>[A|D])!(?:[^@\-!:]+)?->(?<soldiers>[\d]+)").unwrap();
let string = "PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}