package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@(?<planet>[A-Z,a-z]+)(?:[^@\-!:]+)?:(?<population>[\d]+)(?:[^@\-!:]+)?!(?<type>[A|D])!(?:[^@\-!:]+)?->(?<soldiers>[\d]+)`)
var str = `PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}