re = /@(?<planet>[A-Z,a-z]+)(?:[^@\-!:]+)?:(?<population>[\d]+)(?:[^@\-!:]+)?!(?<type>[A|D])!(?:[^@\-!:]+)?->(?<soldiers>[\d]+)/m
str = 'PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end