re = /(?P<l>\d+(\,\d+)?)\s*x\s*(?P<w>\d+(\,\d+)?)\s*x\s*(?P<h>\d+(\,\d+)?)/
str = '23,6 x 34 x 17,1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end