import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<l>\\d+(\\,\\d+)?)\\s*x\\s*(?P<w>\\d+(\\,\\d+)?)\\s*x\\s*(?P<h>\\d+(\\,\\d+)?)";
final String string = "23,6 x 34 x 17,1\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}