package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<l>\d+(\,\d+)?)\s*x\s*(?P<w>\d+(\,\d+)?)\s*x\s*(?P<h>\d+(\,\d+)?)`)
var str = `23,6 x 34 x 17,1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}