$re = '/^(?=(?:\D*.\D*){10,15}$)\+?\d{1,4}?[-.\x20]?\(?\d{1,3}?\)?[-.\x20]?\d{1,4}[-.\x20]?\d{1,4}[-.\x20]?\d{1,9}$/m';
$str = '+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
61 41516
6641516
41516
+1 (418) 827-5338
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);