using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:\D*.\D*){10,15}$)\+?\d{1,4}?[-.\x20]?\(?\d{1,3}?\)?[-.\x20]?\d{1,4}[-.\x20]?\d{1,4}[-.\x20]?\d{1,9}$";
string input = @"+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
61 41516
6641516
41516
+1 (418) 827-5338
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}