const regex = /^(?=(?:\D*.\D*){10,15}$)\+?\d{1,4}?[-.\x20]?\(?\d{1,3}?\)?[-.\x20]?\d{1,4}[-.\x20]?\d{1,4}[-.\x20]?\d{1,9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:\\D*.\\D*){10,15}$)\\+?\\d{1,4}?[-.\\x20]?\\(?\\d{1,3}?\\)?[-.\\x20]?\\d{1,4}[-.\\x20]?\\d{1,4}[-.\\x20]?\\d{1,9}$', 'gm')
const str = `+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
61 41516
6641516
41516
+1 (418) 827-5338
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}