re = /<div id="testId" class="testClass">(.*?)<\/div>/m
str = '<div id="testId" class="testClass">
<div>
<div>
contenty
</div>
<div/>
<div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end