$re = '/<div id="testId" class="testClass">(.*?)<\/div>/ms';
$str = '<div id="testId" class="testClass">
<div>
<div>
contenty
</div>
<div/>
<div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);