import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div id=\"testId\" class=\"testClass\">(.*?)<\\/div>";
final String string = "<div id=\"testId\" class=\"testClass\">\n"
+ "<div>\n"
+ "<div>\n"
+ "contenty\n"
+ "</div>\n"
+ "<div/>\n"
+ "<div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}