const regex = /^((([1-9][0-9]{0,2})(,\d{3})*(\.\d+)?)|(([1-9][0-9]*)(\.\d+)?))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((([1-9][0-9]{0,2})(,\\d{3})*(\\.\\d+)?)|(([1-9][0-9]*)(\\.\\d+)?))$', 'gm')
const str = `0,999,999,999,999,999.0
10,999,999,999,999,9899.9
99,999
9.99
09,999
0999998
09999
9.9
999,99
9,999
999.0
abc123
66666666666666666666.098
888888888
0.999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}