#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((([1-9][0-9]{0,2})(,\d{3})*(\.\d+)?)|(([1-9][0-9]*)(\.\d+)?))$"
Local $sString = "0,999,999,999,999,999.0" & @CRLF & _
"10,999,999,999,999,9899.9" & @CRLF & _
"99,999" & @CRLF & _
"9.99" & @CRLF & _
"09,999" & @CRLF & _
"0999998" & @CRLF & _
"09999" & @CRLF & _
"9.9" & @CRLF & _
"999,99" & @CRLF & _
"9,999" & @CRLF & _
"999.0" & @CRLF & _
"abc123" & @CRLF & _
"66666666666666666666.098" & @CRLF & _
"888888888" & @CRLF & _
"0.999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")