re = /^\/mob_(?:register|activate)\/?$/mi
str = '/mob_activate
/mob_register
/mob_activate/
/mob_register/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end