$re = '/^\/mob_(?:register|activate)\/?$/mi';
$str = '/mob_activate
/mob_register
/mob_activate/
/mob_register/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);