import Foundation
let pattern = #"(((http|https):)?//?)(lkker-10041312\.file\.myqcloud\.com|lkker-10041312\.cossh\.myqcloud\.com|pic\.lkker\.com|files\.lkker\.com|lkker-10041312\.picsh\.myqcloud\.com|lkker-10041312\.image\.myqcloud\.com|images\.lkker\.com)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://lkker-10041312.file.myqcloud.com/Images/201712/SrOq15133074890982.png
http://pic.lkker.com/afdsafds
//images.lkker.com/afdsafds
{"A":"//images.lkker.com/afdsafds", "B":"//images.lkker.com/afdsafds"}
//images.lkker.com/afdsafds|https://images.lkker.com/afdsafds|http://images.lkker.com/afdsafds
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)