#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(((http|https):)?//?)(lkker-10041312\.file\.myqcloud\.com|lkker-10041312\.cossh\.myqcloud\.com|pic\.lkker\.com|files\.lkker\.com|lkker-10041312\.picsh\.myqcloud\.com|lkker-10041312\.image\.myqcloud\.com|images\.lkker\.com)"
Local $sString = "http://lkker-10041312.file.myqcloud.com/Images/201712/SrOq15133074890982.png" & @CRLF & _
"http://pic.lkker.com/afdsafds" & @CRLF & _
"//images.lkker.com/afdsafds" & @CRLF & _
"{"A":"//images.lkker.com/afdsafds", "B":"//images.lkker.com/afdsafds"}" & @CRLF & _
"//images.lkker.com/afdsafds|https://images.lkker.com/afdsafds|http://images.lkker.com/afdsafds"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")