# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(((http|https):)?//?)(lkker-10041312\.file\.myqcloud\.com|lkker-10041312\.cossh\.myqcloud\.com|pic\.lkker\.com|files\.lkker\.com|lkker-10041312\.picsh\.myqcloud\.com|lkker-10041312\.image\.myqcloud\.com|images\.lkker\.com)"
test_str = ("http://lkker-10041312.file.myqcloud.com/Images/201712/SrOq15133074890982.png\n"
"http://pic.lkker.com/afdsafds\n"
"//images.lkker.com/afdsafds\n"
"{\"A\":\"//images.lkker.com/afdsafds\", \"B\":\"//images.lkker.com/afdsafds\"}\n"
"//images.lkker.com/afdsafds|https://images.lkker.com/afdsafds|http://images.lkker.com/afdsafds")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.