$re = '/[5-9]\d{2,}|\d{4,}/m';
$str = '500
100
499
1000
400
1000000
23
5000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);