package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[5-9]\d{2,}|\d{4,}`)
var str = `500
100
499
1000
400
1000000
23
5000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}