#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[5-9]\d{2,}|\d{4,}"
Local $sString = "500" & @CRLF & _
"100" & @CRLF & _
"499" & @CRLF & _
"1000" & @CRLF & _
"400" & @CRLF & _
"1000000" & @CRLF & _
"23" & @CRLF & _
"" & @CRLF & _
"5000" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")