re = /\b(?<word>\w+)\s+(\k<word>)\b/m
str = 'The the quick brown fox fox jumps over the lazy dog dog.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end