$re = '/\b(?<word>\w+)\s+(\k<word>)\b/m';
$str = 'The the quick brown fox fox jumps over the lazy dog dog.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);