package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?<word>\w+)\s+(\k<word>)\b`)
var str = `The the quick brown fox fox jumps over the lazy dog dog.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}