re = /^(?:2[0-3]|[01]\d|\d):[0-5]\d$/m
str = '10:30
18:15
6:24
44:99
00:19
00:00
24:59
23:59
1:12
1:60
13:42'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end