package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:2[0-3]|[01]\d|\d):[0-5]\d$`)
var str = `10:30
18:15
6:24
44:99
00:19
00:00
24:59
23:59
1:12
1:60
13:42`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}