use strict;
my $str = '10:30
18:15
6:24
44:99
00:19
00:00
24:59
23:59
1:12
1:60
13:42';
my $regex = qr~^(?:2[0-3]|[01]\d|\d):[0-5]\d$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}