use strict;
my $str = '[118.0 (09/01/23 17:08:00), 216.0 (09/01/23 17:07:00), 88.0 (09/01/23 17:06:00)]';
my $regex = qr/\[([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20}\]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}