const regex = /\[([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20}\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\\.[0-9][0-9\\(\\)\\\/:\\s]{20},\\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\\.[0-9][0-9\\(\\)\\\/:\\s]{20},\\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\\.[0-9][0-9\\(\\)\\\/:\\s]{20}\\]', 'gm')
const str = `[118.0 (09/01/23 17:08:00), 216.0 (09/01/23 17:07:00), 88.0 (09/01/23 17:06:00)]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}