#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20},\s([2-9][0-9]|[1-9][0-9][0-9][0-9]?)\.[0-9][0-9\(\)\/:\s]{20}\]"
Local $sString = "[118.0 (09/01/23 17:08:00), 216.0 (09/01/23 17:07:00), 88.0 (09/01/23 17:06:00)]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")