import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Amazon(?![^<]*</a>)";
final String string = "I use Amazon for that.\n"
+ "I use <a href=\"http://www.amazon.com\">Amazon</a> for that.\n"
+ "<a href=\"http://www.amazon.com\">My Amazon Link</a>\n"
+ "It will match the \"Amazon\" in \"My Amazon Link\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}