using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Amazon(?![^<]*</a>)";
string input = @"I use Amazon for that.
I use <a href=""http://www.amazon.com"">Amazon</a> for that.
<a href=""http://www.amazon.com"">My Amazon Link</a>
It will match the ""Amazon"" in ""My Amazon Link""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}