#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Amazon(?![^<]*</a>)"
Local $sString = "I use Amazon for that." & @CRLF & _
"I use <a href="http://www.amazon.com">Amazon</a> for that." & @CRLF & _
"<a href="http://www.amazon.com">My Amazon Link</a>" & @CRLF & _
"It will match the "Amazon" in "My Amazon Link""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")