import Foundation
let pattern = #"^(?:rm -r?f?|(?:cp|mv))\b.*?\s/((?:etc|boot|dev|lib(?:64)?|misc|mnt|net|opt|root|sbin|srv|sys|usr|var|bin)(\s|$|/)|home(\s|$|[/]+(?![^/]+[/+])))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"rm -rf /public_html/ /home/dfd/fd"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)