using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:rm -r?f?|(?:cp|mv))\b.*?\s/((?:etc|boot|dev|lib(?:64)?|misc|mnt|net|opt|root|sbin|srv|sys|usr|var|bin)(\s|$|/)|home(\s|$|[/]+(?![^/]+[/+])))";
string input = @"rm -rf /public_html/ /home/dfd/fd";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}